Banner-baigiang-1090_logo1
Banner-baigiang-1090_logo2
TSThS

Tìm kiếm theo tiêu đề

Tìm kiếm Google

Quảng cáo

Hướng dẫn sử dụng thư viện

Hỗ trợ kĩ thuật

Liên hệ quảng cáo

  • (024) 66 745 632
  • 036 286 0000
  • contact@bachkim.vn

Configuring Dial on Demand Routing

Wait
  • Begin_button
  • Prev_button
  • Play_button
  • Stop_button
  • Next_button
  • End_button
  • 0 / 0
  • Loading_status
Nhấn vào đây để tải về
Báo tài liệu có sai sót
Nhắn tin cho tác giả
(Tài liệu chưa được thẩm định)
Nguồn: Cisco
Người gửi: Nguyễn Việt Vương
Ngày gửi: 18h:56' 21-09-2016
Dung lượng: 1.1 MB
Số lượt tải: 3
Số lượt thích: 0 người
© 2002, Cisco Systems, Inc. All rights reserved.
© 2002, Cisco Systems, Inc. All rights reserved.
2
Configuring Dial-on-Demand Routing
Objectives
Upon completing this lesson, you will be
able to:
Configure legacy DDR, given a functioning remote access router and a physical ISDN connection
Use show commands to identify the anomalies in the legacy DDR configurations, given a functioning remote access router and a physical ISDN connection
Use debug commands to identify the anomalies in the legacy DDR configurations, given a functioning remote access router and a physical ISDN connection
Connects when needed
Disconnects when finished
ISDN or PSTN
What Is Dial-on-Demand Routing?
When to Use DDR
Periodic connections
Small amounts of data
1. Route to destination is determined.
2. Interesting packets dictate DDR call.
3. Dialer information is looked up.
4. Traffic is transmitted.
5. Call is terminated.
Generic DDR Operation
1
Define static routes—What route do I use?
Specify interesting traffic—What traffic enables the link?
Configure the dialer information—What number do I call?
Configuring DDR
Defining Static Routes
dialer-list 1 protocol ip permit
dialer-list 1 protocol ip list 101

access-list 101 deny tcp any any eq ftp
access-list 101 deny tcp any any eq telnet
access-list 101 permit ip any any
Any IP traffic will initiate the link without access lists.
Any IP traffic, except FTP and Telnet, will initiate the linking.
Using access lists gives finer control.
Denies FTP
Denies Telnet
Specifying Interesting Traffic
Applies rules defined by dialer-list to individual interfaces
hostname Home
!
isdn switch-type basic-5ess
!
username central password cisco
interface BRI0
ip address 10.1.0.1 255.255.255.0
encapsulation ppp
dialer idle-timeout 180
dialer map ip 10.1.0.2 name Central 5552000
dialer-group 1
no fair-queue
ppp authentication chap
!
router rip
network 10.0.0.0
!
no ip classless
ip route 10.10.0.0 255.255.0.0 10.1.0.2
ip route 10.20.0.0 255.255.0.0 10.1.0.2
!
dialer-list 1 protocol ip permit
Both Values
Must Match
Configuring the Dialer Information
Configuring the Dialer Information (Cont.)
Establishes the amount of traffic on the link before a second link is enabled
Router(config-if)#dialer idle-timeout seconds
Optional Legacy DDR Commands
Router(config-if)#dialer load-threshold load
[outbound | inbound | either]
Establishes the idle time before disconnect
1
3
2
hostname Home
!
isdn switch-type basic-5ess
!
username central password cisco
interface BRI0
ip address 10.1.0.1 255.255.255.0
encapsulation ppp
dialer idle-timeout 180
dialer map ip 10.1.0.2 name Central 5552000
dialer-group 1
no fair-queue
ppp authentication chap
!
router rip
network 10.0.0.0
!
no ip classless
ip route 10.10.0.0 255.255.0.0 10.1.0.2
ip route 10.20.0.0 255.255.0.0 10.1.0.2
dialer-list 1 protocol ip permit
!
Legacy DDR Configuration Tasks Summarized
Dialer Profiles Overview
Dialer Profile Elements
Dialer Profile Configuration Concepts and Commands
Configuring Dialer Interfaces
interface dialer1
ip address 10.1.1.1 255.255.255.0
encapsulation ppp
dialer remote-name Smalluser
dialer string 5554540
dialer idle-timer 180
dialer pool 1
dialer-group 1
ppp authentication chap
!
interface dialer2
ip address 10.2.2.1 255.255.255.0
encapsulation ppp
dialer remote-name Mediumuser
dialer string 5551234
dialer idle-timer 180
dialer pool 1
dialer-group 2
(cont.)
interface dialer3
ip address 10.3.3.1 255.255.255.0
encapsulation ppp
dialer remote-name Poweruser
dialer string 4155554321
dialer idle-timer 300
dialer pool 1
dialer-group 3
Configuring Physical Interfaces
Router#ping or telnet
Router#show dialer
Router#show isdn active
Router#show isdn status
Triggers a link
Displays current status of the link
Displays call status while call is in progress
Displays the status of an ISDN connection
Router#show ip route
Displays all routes, including static routes
Verifying DDR and ISDN Operation
NASX#show dialer interface bri0


Dial String Successes Failures Last called Last status
5553872 6 0 19 secs Successful
0 incoming call(s) have been screened.
BRI0: B-Channel 1
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)





Time until disconnect 102 secs
Current call connected 00:00:19
Connected to 5553872 (system1)


BRI0: B-Channel 2
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
BRI0 - dialer type = ISDN
Interface bound to profile Dialer0
Dialer state is data link layer up
Dial reason: ip (s=10.1.1.8, d=10.1.1.1)
Verifying Dialer Profiles Operation
Router#debug dialer [events | packets]
Displays DDR debugging information about the packets received on a dialer interface
Clears currently established connections from the interface
Router#debug isdn q921
Shows ISDN Layer 2 messages
Router(config-if)#shutdown
Troubleshooting DDR and ISDN Operation
Shows ISDN call setup and teardown activity
Router#debug isdn q931
debug isdn q921 Example
Router#debug isdn q921

Jan 3 14:52:24.475: ISDN BR0: TX -> INFOc sapi = 0 tei = 64 ns = 5 nr = 2
i = 0x08010705040288901801837006803631383835
Jan 3 14:52:24.503: ISDN BR0: RX <- RRr sapi = 0 tei = 64 nr = 6
Jan 3 14:52:24.527: ISDN BR0: RX <- INFOc sapi = 0 tei = 64 ns = 2 nr = 6
i = 0x08018702180189
Jan 3 14:52:24.535: ISDN BR0: TX -> RRr sapi = 0 tei = 64 nr = 3
Jan 3 14:52:24.643: ISDN BR0: RX <- INFOc sapi = 0 tei = 64 ns = 3 nr = 6
i = 0x08018707
Jan 3 14:52:24.655: ISDN BR0: TX -> RRr sapi = 0 tei = 64 nr = 4
%LINK-3-UPDOWN: Interface BRI0:1, changed state to up
Jan 3 14:52:24.683: ISDN BR0: TX -> INFOc sapi = 0 tei = 64 ns = 6 nr = 4
i = 0x0801070F
Jan 3 14:52:24.699: ISDN BR0: RX <- RRr sapi = 0 tei = 64 nr = 7
%LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to up
%ISDN-6-CONNECT: Interface BRI0:1 is now connected to 61885 goodie
Jan 3 14:52:34.415: ISDN BR0: RX <- RRp sapi = 0 tei = 64 nr = 7
Jan 3 14:52:34.419: ISDN BR0: TX -> RRf sapi = 0 tei = 64 nr = 4
debug isdn q931 Examples
Router#debug isdn q931

TX -> SETUP pd = 8 callref = 0x04
Bearer Capability i = 0x8890
Channel ID i = 0x83
Called Party Number i = 0x80, `415555121202`
RX <- CALL_PROC pd = 8 callref = 0x84
Channel ID i = 0x89
RX <- CONNECT pd = 8 callref = 0x84
TX -> CONNECT_ACK pd = 8 callref = 0x04....
Router#debug isdn q931

RX <- SETUP pd = 8 callref = 0x06
Bearer Capability i = 0x8890
Channel ID i = 0x89
Calling Party Number i = 0x0083, `81012345678902`
TX -> CONNECT pd = 8 callref = 0x86
RX <- CONNECT_ACK pd = 8 callref = 0x06
Call Setup
Procedure for
Outgoing Call
Call Setup
Procedure for
Incoming Call
debug dialer Examples
Router#debug dialer events

Dialing cause: Serial0: ip (s=172.16.1.111 d=172.16.2.22)
Router#debug dialer packets

BRI0: ip (s=10.1.1.8, d=10.1.1.1), 100 bytes, interesting (ip PERMIT)
Resolving Outbound Call Problems
Cause

Missing or incorrect “interesting traffic” definitions

Incorrect interface state


Misconfigured dialer map

Misconfigured dialer profile
Suggested Actions

Verify the configuration using show running-configuration


Ensure that the interface state is “up/up” (spoofing)

Make sure the dialing interface has at least one dialer map statement

Make sure the dialer interface is configured with a dialer pool X command
Summary
Dial-on-demand routing refers to a collection of Cisco features that allows two or more Cisco routers to establish a dynamic connection over simple dialup facilities.
DDR operates by first determining the route to the destination, then, if the traffic is “interesting,” initiating a call.
To configure DDR, first define the static routes, then specify interesting traffic, and finally configure the dialer information.
Use static routes across a DDR link so that the number is not dialed just for routing updates.
Summary (Cont.)
DDR calls are triggered by “interesting” traffic, which can be defined based on protocol, source address, destination address, or a variety of other criteria.
Use the dialer-group and dialer map commands on an interface to associate a port and dialer-string with a
dial list.
To configure ISDN PRI with legacy DDR, you will configure dialer rotary groups and dialer profiles.
You use show commands to display information about DDR configuration.
You can use debug commands to help troubleshoot problems with a DDR configuration.
 
Gửi ý kiến